2012年12月2日

たった2行で IE 対策が出来る魔法があると聞いて飛んできました!!

スポンサード リンク

IE Logo

毎度です、 @Ebba_oBL です。

最近注目しているブログ、A!@attrip さんの記事に、食いつかざるを得ないネタが上がっていましたのでご紹介です。

たった2行でIE5.5~IE8をモダンブラウザの挙動にする魔法のJS | A!@attrip

既に IE6 対策についてはさじを投げてしまった当ブログでしたが、たった2行で対応できるとあればやらないわけにも行かないだろう!ということで、ちゃっかり採用させていただきました。

<!--&#91;if lt IE 9&#93;>
<script src="http://ie7-js.googlecode.com/svn/version/2.1(beta4)/IE9.js"></script>
<script src="http://css3-mediaqueries-js.googlecode.com/svn/trunk/css3-mediaqueries.js"></script>
<!&#91;endif&#93;-->

このスクリプトを読み込ませるだけで、IE 5.5 〜 IE8 をモダンブラウザの挙動にしてしまうということです。

透過PNG も使えますし、レスポンシブデザインも IE で再現できるということ。

ただし、border-radius (角丸) や box-shadow(要素の影) は出来ないという事なので、それについては引き続き PIE で対応すればいいんじゃないかなと。

PIE.htc についてはこんな記事を書いています。

自作Wordpressテーマ:今更ながらIEの描画チェックしてみた | ハヤクユケ

何もしないよりは…いいかなって感じです(;´Д`)

【追記】この記事には後日談があります。

IE をモダンブラウザに変身させる魔法の js 2行のうち1行は地雷だった件 | ハヤクユケ

スポンサード リンク

コメントを残す

TOP↑